mercredi 5 janvier 2022

firmware CS MK1 060 v1.1

Voici maintenant la version 060. Il y a un soucis avec le fichier firmware original "cyberstormmk1_060.rom" fournit dans le package roms de WinUAE et cet émulateur : reset infini au boot...

J'ai trouvé le bug et transmis à Toni en espérant qu'il le corrige dans ses futurs versions...

Par contre, mes deux nouveaux firmwares 060 fonctionnent bien avec la version 4.9.1 beta, j'ai réussi à contourner le problème propre à WinUAE.

Désolé, impossible de réunir les trois libraries 040/060 en une seule eprom faute de place.
 
Cette nouvelle version 1.1 spéciale 68060 est en deux fichiers contenant :
  • 68060.library 46.27 et 68040tiny.library 46.9 pour 68060 avec MMU et FPU sans kit Scsi
  • 68060.library 46.27 et 68040tiny.library 46.9 pour 68060 avec MMU et FPU avec kit Scsi
 
La version avec kit Scsi doit tout de même démarrer si son kit est absent, mais n'en étant pas certain, je préfère diffuser deux versions, l'une donc avec la cybscsi.device 8.5 et l'autre sans.
 
A été testé uniquement sous WinUAE 4.9.0/4.9.1 pour l'instant :
Petit WhichAmiga bug qui détecte la MK1 comme étant une Blizzard 1220 !

Là encore, si vous testez chez vous, merci de m'envoyer un email avec quelques photos ou une courte vidéo : comme il fonctionne sous WinUAE, il y a de très grandes chances qu'il marche aussi sur le vrai matériel.
 
Comme d'habitude, tout est disponible ici... 
    

9 commentaires:

  1. Hi! I tried to install a new firmware in my A4000D on Cyberstorm MK1 060 . The Amiga has started, but the 68060 and 68040 libraries are missing from the system!

    RépondreSupprimer
    Réponses
    1. Oh ?

      Have you some fastram installed ?

      And have you checked with Scout ?

      Which version have you tried ? The one with the scsi or not ?

      Supprimer
    2. And have you deleted the 68040.library and the 68060.library from Sys:Libs/ ?

      Which Kickstart are you using ?

      Supprimer
    3. Two 32 - megabyte memory blocks are installed in the accelerator . 16 megabytes are installed on the motherboard. Libraries have been removed from the system. Kickstart and system 3.2.1 .

      Supprimer
  2. The version that is noscsi. No program libraries are visible.

    RépondreSupprimer
    Réponses
    1. I tried only with the Kick 3.1

      Do you have the 3.2.1 in file for the 4000D : for checking with WinUAE to see...

      Supprimer
    2. Let me know your email and I'll send you a link.

      Supprimer
  3. Ok, finally found what is wrong, the new version 1.2 is fully working under 3.2.1 without Scsi...

    RépondreSupprimer

Posté vos remarques :